Dienstag, November 4 2008

Compiz Fusion und flackerndes Video

Auch Ibex hat seine Schattenseiten, die mir nach dem Update offenbart wurden. Scheinbar ist der neue fglrx Treiber noch fehlerhaft, denn er erzeugt im Zusammenhang mit Compiz Fusion ein Bildflackern bei der Wiedergabe von Videos. Und das sowohl im Fenster, als auch im Vollbildmodus. Sämtliche Konfigurationen wollten mit aktiviertem Compiz nicht funktionieren, nur der X11 Treiber ohne Renderunterstützung der Grafikkarte, was sich sogleich durch leichtes Ruckeln und eine insgesamt "rumpelige" Wiedergabe und eine enorme CPU Belastung äusserte. Hierzu muss allerdings gesagt werden, dass es sich bei der Videodatei um ein Matroska Video in 720p mit avc1 und a52 Codec handelte. Das war nicht hinnehmbar und so suchte ich nach Lösungen, die ich auch sogleich fand:
Section "Device" ........ Option "VideoOverlay" "off" Option "OpenGLOverlay" "on" Option "TexturedVideo" "off" ......... EndSection
sollte der /etc/X11/xorg.conf hinzugefügt werden, wobei bei mir nur die Option TexturedVideo Wirkung zeigte. Das Flackern war Verschwunden, aber die Wiedergabe nach wie vor nicht in Ordnung, denn die Option schien einfach nur die "Hilfe" der Grafikkarte zu blockieren. Nach langem Probieren mit Codecs, alternativen Wiedergabegeräten a la xvmc, x11 mit sämtlichen OpenGL Varianten, xv usw. und auch mehreren Player Frontends, komme ich zum Entschluss: Irgendetwas scheint im neuen fglrx Treiber noch nicht rund zu laufen! Deaktiviert man Compiz läuft die Wiedergabe des og. Matroska HD Videos einwandfrei, flüssig und wie gewohnt mit Renderunterstützung der Grafikkarte. Das An- und Ausgeschalte von Compiz ist zwar leider etwas nervig, aber für mich im Moment die einzige wirksame Methode. Hoffen wir auf eine schnelle Behebung! Abschliessend vielleicht noch interessant: Bei meiner Karte handelt es sich um eine ATI Radeon Mobility X1700 im Notebook.