linux - net - tech and fun

Zum Inhalt | Zum Menü | Zur Suche

Montag, Mai 16 2011

Ich mach mal eben nen Jailbreak...

... oder: die komplizierte Geschichte eines Updates. Viele Otto-Normalnutzer sind mit ihrem iPhone und dessen Betriebssystem iOS vollkommen zufrieden und wissen gar nicht was ein Jailbreak überhaupt ist, geschweige denn wie man das iPhone überhaupt updatet. Manchmal sind diese Leute tatsächlich zu beneiden, denn sie ersparen sich unter Umständen viel Ärger. Wer sein iOS Device mit einer neuen Firmware versorgen will, macht natürlich zuerst einmal ein Backup seines Geräts; und das dauert... und dauert... und dauert... und.... wo ist iTunes?! Abgestürzt! Verdammt! Das Ganze noch einmal... Und endlich klappts! Puh, ein großer Schritt ist geschafft. Nun die zuvor geladene Firmware Datei mit dem Shift-Trick wiederherstellen: Klick, ... überprüfe Firmware Update mit Apple... und klack Fehler 3195 - Toll! Hin und her, Tiny Umbrella, neustart und irgendwie klappts dann. Ist die neue Firmware endlich drauf, kanns losgehen mit dem Jailbreak! Juhu! RedSn0w ist das Mittel zum Zweck, Firmware File laden... huch, abgestürtzt... nochmal das Ganze. Nun klappts endlich! Jetzt noch den DFU Mode hinfummeln, zum Glück ist das jetzt im Programm interaktiv für Idioten erklärt, also kein Problem! AHA! "Waiting for iPhone to reboot..." Da warte ich mit... irgendwie scheint es nicht zu wollen. Hmmmmm... Also iPhone reset, nochmal die ganze Prozedur. Und wer hätte es gedacht, diesmal klappts! Jailbreak gemacht! Kein Problem oder? :)

Montag, November 2 2009

USB Support in Virtualbox unter Ubutu Karmic

Das altbekannte Problem mit USB Geräten in einem Virtalbox Gast ist auch in Karmic Koala nicht behoben. Hier kann man allerdings nicht mehr vorgehen, wie ich in diesem Artikel beschrieben habe, weil sich bei Karmic einiges "unter der Haube" getan hat und das Script mountkerfs.sh nicht mehr existiert. Dennoch lässt sich der USB Support wieder leicht und schnell aktivieren: Zuerst den eigenen Benutzer zur Gruppe "vboxusers" hinzufügen, dies kann über die "Benutzer und Gruppen"-GUI unter System --> Systemverwaltung geschehen. Um Zugriff auf die USB Geräte zu aktivieren, muss zuerst wieder die Gruppen ID der vboxusers Gruppe herausgefunden werden. Die geschieht per cat /etc/group|grep vboxusers , was in meinem Fall die Ausgabe vboxusers:x:121:nox liefert. Die Zahl, hier 121 ist die Gruppen ID. Nun öffen wir die Datei /etc/fstab mit Root Rechten in einem Editor (z.B. per sudo gedit /etc/fstab ) und fügen am Ende folgende Zeilen ein: #virtualbox USB fix none /proc/bus/usb usbfs devgid=121,devmode=664 0 0 Wichtig hierbei ist, das hinter devgid die korrekte Gruppen ID eingetragen wird! Dann die Datei speichern und den Rechner neu booten, danach sollten sämtliche USB Geräte mit Virtualbox benutzt werden können. Refernzsystem ist hier Ubuntu Karmic Koala AMD64 Kernel 2.6.31-14-generic mit Virtual Box 3.0.10-54097 Ubuntu Karmic amd64.

Mittwoch, April 29 2009

ia32-lib, apt und debian

Dieser Titel mag beim ersten Lesen etwas verwirren, doch Aufklärung folgt sofort. Um i386 Pakete auf einem AMD64 System nutzen zu können, werden die ia32 Bilbliotheken benötigt. Ohne viel zu überlegen tat ich dies und installierte dabei ia32-apt-get was sich später als fataler Fehler herausstellen sollte. Natürlich war ich mir meines Fehlers nicht bewusst und arbeitete derweil fröhlich mit dem Rechner weiter. Als ich jedoch auf updates prüfen wollte und im Terminal sudo apt-get update eingab, fühlte sich mein "altes" Apt nicht mehr verantwortlich und ia32-apt-get sprang sattdessen ein. Zuerste aktualisierte es seine Quellen, allerdings nicht wie gewohnt die Ubuntu Sources, sondern Debian Sid Sources! Danach fing apt an sämtliche Bibliotheken unzukonvertieren (nach 32-bit??), was ich schleunigst abbrach. Sofort prüfte ich die sources.list, doch hier war alles normal, kein Anzeichen für irgendwelche Debian Quellen irgendwo. Nach einiger Suche stellte ich fest, dass der Übeltäter ia32-apt-get sein musste und deinstallierte (purge) es. Endlich klappte auch wieder apt-get update und nach dem Entfernen der plötzlich vorhandenen i386 Quellen war alles wieder wie gewohnt. Schock abgwendet

Sonntag, März 29 2009

Mit dem Zweiten sieht man besser...

...nicht hin! Den Leuten, denen es beim Fussballländerspiel gestern nicht aufgefallen ist: liewas Das Land "Liechstenstein" ist mir nicht bekannt... vielleicht klärt mich jemand auf? :) Ein Hoch auf das öffentlich rechtliche Fernsehn!

Dienstag, März 10 2009

Pidgin "Ihre Version ist zu alt"

Die Horrormeldung für alle Pidgin-Instantmessengernutzer: "Die Client-Version, die Sie nutzen ist zu alt. Bitte updaten Sie unter http://pidgin.im", kein ICQ, kein Chat und kein Update in Sicht!?. Dabei ist die Lösung für alle Eiligen ganz simpel: http://www.getdeb.net/app/Pidgin Hier die 4 .deb Pakete für die jeweilige Architektur herunterladen (Version 2.5.5) und nach vorherigem deinstallieren der alten Pakete pidgin, pidgin-data, libpurple0 und libpurple-bin mit dem Befehl: sudo apt-get remove pidgin* libpurple* Können die neuen Pakete mit sudo dpkg -i pidgin* libpurple* installiert werden. Natürlich muss man sich ich Verzeichnis befinden, worin die Dateien auch liegen. Damit sollte der Fehler behoben sein und alles wieder wie gewohnt funktionieren, auch mit 64bit OS.

Freitag, Februar 20 2009

Permalinks crashen Wordpress!

Nachdem ich die äusserst kluge Idee hatte, Permalinks auf meinem Blog einzuführen, bin ich nun so klug jedem zu raten, dies tunlichst zu unterlassen! Das Einstellen der Permalinks hat das komplette Blog zerschossen! Error 404, Error 403 oder auch Error 500 (Internal Server Error), alles habe ich dabei gesehen. Durch stundenlange Googlei habe ich auch nicht viel gefunden, sodass ich die Lösung selbst erarbeiten musste, die ich gerne hier vorstellen möchte: 1. Durch die Umstellung auf Permalinks, hat Wordpress die Datei .htaccess im Root Verzeichnis von Wordpress geändert. Löscht man diese, hat man nun zumindest schon mal wieder Zugriff auf das Admin Backend. 2. Jetzt unter --> Einstellungen --> Permalinks  die Einstellung wieder auf Standart ändern. Das sollte mal wieder einen Error 403 hervorrufen, aber die Einstellungen sollten trotzdem übernommen worden sein. 3. Nochmal die .htaccess löschen, damit wir wieder ins Backend kommen. Klicken wir wieder auf Permalinks, sollte der Radiobutton wieder auf Standart eingestellt sein. Noch können wir aber trotzdem nicht auf das Blog zugreifen. Eine weitere Möglichkeit zu prüfen, ob die Links wieder zurückgesetzt wurden, ist einen Artikel anzuzeigen. Klappt das, sollte einer erfolgreichen Wiederherstellung nichts im Weg stehen. 4. Jetzt klicken wir auf Werkzeuge --> Aktualisieren --> Automatisch Reinstallieren. Danach war bei mir der Fehler behoben und ich konnte wieder normal auf Blog und Adminbackend zugreifen. Die Anleitung bezieht sich auf Wordpress 2.7.1! Viel Erfolg!

Montag, Februar 16 2009

CIFS VFAT Shutdown Error

Wer feste Netzwerkfreigaben in seinem System eingebunden hat, die auf Samba basieren, kennt vielleicht diese oder eine ähnliche Fehlermeldung:
CIFS VFS: server not responding. 
No response for cmd 50 ...
So oder so ähnlich. Eigentlich nicht weiter schlimm, würde dies das Herunterfahren des Rechners nicht enorm herauszögern. Das Problem liegt darin, dass das Netzwerk beim Shutdown bereits deaktiviert wurde bzw. die Module entladen, die Cifs Freigabe aber immernoch gemountet ist. Da die Freigabe auf Grund der nicht mehr vorhandenen Netzverbindung nicht mehr getrennt werden kann, kommt es zu diesem Fehler. Um ihn zu beheben muss dafür gesorgt werden, dass die umountnfs.sh früher ausgeführt wird (in S14 statt erst in S31). Dazu geben wir folgendes ein: sudo mv /etc/rc0.d/S31umountnfs.sh /etc/rc0.d/S14umountnfs.sh sudo mv /etc/rc6.d/S31umountnfs.sh /etc/rc6.d/S14umountnfs.sh Danach sollte das System ohne Murren herunterfahren und das Networkshare ordentlich trennen.

Freitag, August 29 2008

Cue-Sheet Abbilder brennen

Nun bin ich schon öfter auf das folgende Problem gestossen: Ich möchte ein Cue-Sheet CD Image brennen, jedoch scheint das keinem Brennprogramm möglich zu sein, denn alle brechen vorzeitig mit einem Fehler ab, die .bin Datei könne nicht gefunden werden. Das Problem scheint darin zu bestehen, dass in der .cue Datei die .bin Datein des Images ohne Pfadangabe steht und sie dadurch nicht gefunden werden kann. Ich löse das Problem durch Voranstellen des kompletten Pfads. Zb.: FILE "file.bin" BINARY TRACK 01 MODE1/2352 INDEX 01 00:00:00 ändern nach FILE "~/ISO/file.bin" BINARY TRACK 01 MODE1/2352 INDEX 01 00:00:00 Dann klappts auch mit dem Brennen!